Wednesday, November 17, 2010

Oracle Solaris 11 Express released

Oracle announces immediate availability of Oracle Solaris 11 Express, a fully supported, production-ready environment that builds on existing Oracle Solaris 10 features with more than 2,700 new projects and 400 significant innovations.
for more details
http://www.oracle.com/us/products/servers-storage/solaris/solaris-11-express-185123.html

Wednesday, May 26, 2010

Useful Solaris Commands

1. Display system information
#uname –a

2. Diplay processor information
#psrinfo –v

3.Display hostname
#hostname
#cat /etc/hosts

4.Dispaly domain name
#domainname
#cat /etc/defaultdomain

5. Display installed memory configuration

#prtconf | grep memory

6.To get installed Network card status
#dladm show-dev

7. Display Routing table information
#netstat –nr

8. Display virtual memory information
#swap –l
#swap –s

9. Display Disks error information
#iostat –E

10. Diplay memory status
#vmstat –p

11. Display interrupts status
#vmstat –ip

12. Dispaly Disk usage information
#df –hk

13. Dispaly system events since last reboot
#vmstat –s

14. Display swapping statistics
#vmstat –S

15. Display cache flushing statistics
#vmstat –c

16. To check buffer activities
#sar -b

17. To check system call activities
#sar –c

18.To check unused memory statistics
#sar –r

19.To check CPU utilization
#sar -u

20.Dispaly OBP version
#prtconf -v

21.Display installed packages
#showrev
#pkginfo

22.To get HBA card details
#fcinfo hba-port
#luxadm -e

23.To get running process status
#prstat
#ps -ef

24.To get hardware details
#prtdiag

Tuesday, May 25, 2010

Configuring RAID5 with hot spare using SVM

I`ve planned to create RAID 5 volume with 7 HDD and one HDD for Hot spare.

1.I`m creating RAID5 volume using metainit command.In this -r represent RAID5 volume
bash-2.03# metainit d50 -r c4t0d0s0 c4t1d0s0 c4t2d0s0 c4t8d0s0 c4t9d0s0 c4t10d0s0 c4t11d0s0
d50: RAID is setup

2.type metastat command to verify the RAID 5 status
bash-2.03# metastat d50
d50: RAID
State: Initializing
Initialization in progress: 0% done
Interlace: 32 blocks
Size: 210141064 blocks
Original device:
Size: 210143616 blocks
Device Start Block Dbase State Hot Spare
c4t0d0s0 330 No Initializing
c4t1d0s0 330 No Initializing
c4t2d0s0 330 No Initializing
c4t8d0s0 330 No Initializing
c4t9d0s0 330 No Initializing
c4t10d0s0 330 No Initializing
c4t11d0s0 330 No Initializing

3.After I created the RAID 5 volume I`m creating one Hot spare spool(hsp001) and assign one HDD to this pool(c4t12d0s0)
bash-2.03# metainit hsp001 c4t12d0s0
hsp001: Hotspare pool is setup

4.finally I`m assigning this hot spare spool to RAID5 volume d50
bash-2.03#metaparam -h hsp001 d50

5.verify whether the hot spare disk is assigned to RAID5 volume using metastat command
bash-2.03# metastat d50
d50: RAID
State: Initializing
Initialization in progress: 84% done
Hot spare pool: hsp001
Interlace: 32 blocks
Size: 210141064 blocks
Original device:
Size: 210143616 blocks
Device Start Block Dbase State Hot Spare
c4t0d0s0 330 No Initializing
c4t1d0s0 330 No Initializing
c4t2d0s0 330 No Initializing
c4t8d0s0 330 No Initializing
c4t9d0s0 330 No Initializing
c4t10d0s0 330 No Initializing
c4t11d0s0 330 No Initializing