Friday, July 10, 2009

Jumpstart server Configuration on Solaris10

I configured Jumpstart server for Solaris 10 client last week.

Create one directory and share that directory using NFS
#mkdir -m 775 /vol/install
#vi /etc/dfs/dfstab

share -F nfs -o ro,anon=0 /vol/install
#shareall


insert your SUN Solaris10 DVD to your DVD drive and goto following directory
#cd /cdrom/cdrom0/s0/Solaris_10/Tools

Run setup_install_server command to copy installation files to install base directory(/vol/install) It takes some time...
# ./setup_install_server /vol/install/
Verifying target directory...
Calculating the required disk space for the Solaris_10 product
Calculating space required for the installation boot image
Copying the CD image to disk...
Copying Install Boot Image hierarchy...
Install Server setup complete


Jumpstart server required 3 configuration files.
1.rules [this is a first config file accessed by client to read profile file file]
2.sysidcfg [This file is having values which are required for client initial boot ]
3.Profile file [This file has filesystems,patch details]


Make config directory under install folder and you can copy sample configuration files from DVD which are reside under Misc folder.I`ve copied only check and any_machine files.Remaining files I`ve created manually.


#mkdir /vol/install/config
#cd /cdrom/cdrom0/s0/Solaris_10/Misc/jumpstart_sample/
# cp check /vol/install/config
# cp any_machine /vol/install/config

# ./setup_install_server -b /vol/install/boot

Verifying target directory...
Calculating space required for the installation boot image
Copying Solaris_10 Tools hierarchy...
Copying Install Boot Image hierarchy...
Install Server setup complete


#vi rules
hostname sunserver1 - e250_prof -
any - - any_machine -
in this above
sunserver1 --> client name
e250_prof -->profile file name.
My sunserver1 is a Sun E250 model server,so I created this name:)


#vi e250_prof
# profile keywords profile values
# -------- ------ --------- --------
install_type initial_install
cluster SUNWCXall
partitioning explicit
filesys c0t0d0s0 12000 /
filesys c0t0d0s3 3072 swap
system_type server


#vi sysidcfg
system_locale=en_US
timezone=Asia/Calcutta
timeserver=localhost
terminal=vt100
name_service=NONE
security_policy=NONE
root_password=kFEEDxSc4v2E6
network_interface=hme0 {hostname=sunserver1
netmask=255.0.0.0
ip_address=10.1.1.4
protocol_ipv6=no
default_route=10.1.1.1}

update your client MAC address and name into /etc/ethers file
#vi /etc/ethers
8:0:xx:xx:xx:xx sunserver1

update your client IP address and name into /etc/hosts file
#/etc/hosts
1.1.1.4 sunserver1

Jumpstart server uses TFTP protocol, so check whether the TFTP entry has commented out or not in inetd.conf file.
#vi /etc/inet/inetd.conf
tftp dgram udp6 wait root /usr/sbin/in.tftpd in.tftpd -s /tftpboot

#eject cdrom

# /vol/install/Solaris_10/Tools/add_install_client -e 8:0:xx:xx:xx:xx -s 1.2.3.4:/vol0/install -c 1.2.3.4:/vol0/install/config -p 1.2.3.4:/vol0/install/config sunserver1 sun4

updating /etc/bootparams
[1.2.3.4 is IP address of jumpstart server]


##########
#### Client Side ########
##########
ok>boot net - install

Thursday, May 7, 2009

Common Desktop Environment Help

To disable the login server from starting automatically
# /usr/dt/bin/dtconfig -d
done
desktop auto-start disabled.

to kill login server,X server and entire soalris CDE Desktop
# /usr/dt/bin/dtconfig -kill
done
dtlogin kill complete.

Check if login manager is running
# ps -ef grep dtlogin
root 17621 16732 0 23:47:03 pts/8 0:00 grep dtlogin

To start the login server from command line
#/usr/dt/bin/dtlogin -daemon;exit

To enable the login server from starting automatically
# /usr/dt/bin/dtconfig -e
(This will add a S99dtlogin file to /etc/rc2.d directory

Thursday, January 1, 2009

Un-Mirrored root Volume

Check the root mirror status
#metastat d0
this command will update /etc/vfstab and /etc/system file for root disk
#metaroot /dev/dsk/c0t0d0s0
#reboot
....
#metaclear -r d0
#metaclear d20

Creating Mirror for mounted usr volume

#metainit -f d12 1 1 c0t0d0s3
#metainit d22 1 1 c0t1d0s3
#metainit d2 -m d12
#reboot
after reboot you have to run following command
#metattach d2 d22
After created mirror disk for usr volume you need to edit the /etc/vfstab file entry
#vi /etc/vfstab
/dev/md/dsk/d2 /dev/md/rdsk/d2 /usr ufs 1 yes -
:wq!

Creating Mirror for mounted root volume

#metainit -f d1 1 1 c0t0d0s0
#metainit d2 1 1 c0t1d0s0
#metainit d0 -m d1
#metaroot d0 (this will update /etc/vfstab & /etc/system file)
#metaroot d0
#
lockfs -fa
#reboot
after reboot you have to run following command
#metattach d0 d2
After created mirror disk for root volume you need to configure alternate boot path for this server.in case the first disk crashed the system will boot from second disk automatically.to find the physical path
#ls -l /dev/rdsk/c0t1d0s0
devices/sbus@1,f8000000/esp@1,200000/sd@3,0:a
goto OK prompt
create alias for second disk
ok: nvalias backup-root /sbus@1,f8000000/esp@1,200000/sd@3,0:a
ok:printenv boot-root
ok:
setenv boot-device disk backup-root net
ok>nvstore
for manual boot
ok:boot backup_root